Wandb: Network error (SSLError), entering retry loop

Its my first time to use wandb and I’m having issue with the initialisation. I did enter my API key.

This issue get triggered when I call wandb.init():
wandb: Network error (SSLError), entering retry loop.
wandb: W&B API key is configured. Use wandb login --relogin to force relogin

I tried relogin many times but same issue keeps recurring. Could you please advise?

Hi @ahmadamer , happy to help. Could you try the following.

  • Delete your netrc file storing your credentials, rm ~/.netrc
  • Refresh your login wandb login --relogin --cloud
  • Try the following, does it succeed
import wandb
wandb.init(entity="<your-entity>", project="test-project") 

Hi @ahmadamer , since we have not heard back from you we are going to close this request. If you would like to re-open the conversation, please let us know!

Hi @mohammadbakir, I have the same issue. I tried to delete .netrc and relogin, but wandb.init still gives me the SSLError.
By the way, I am on a HPC cluster which possibly uses proxy to connect to the internet (here’s a similar situation). But I don’t know how to confirm this is the problem.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.