Unable to login using wandb local

Python: 3.9.7
wandb: 0.12.17
OS: Ubuntu 20.04.4 LTS

Yesterday (08 Aug) I was able to login and view my training artifacts using wandb local. However, today I am unable to do so. Here are the commands I run:

conda activate my_env
wandb local

I then navigate in my browser to localhost:8080. I’m taken to a page that says “Developer Tools for Deep Learning” and click the Login button in the upper right corner. The url is redirected to http://localhost:8080/login?local=true and I am presented with the login fields. I login using the same credentials I used yesterday (and the same ones that gave me access to the wandb forum and the ability to make this post), but get an error saying “Invalid password”.

I tried resetting the password but I get another error that says “Error while trying to reset password”.

Any thoughts about what might be going on? If need be, I’m fine with completely wiping the user account and starting over as I don’t have anything of real value uploaded. Thanks in advance for your help!

Hi @aclifton314 . Perform the following from your terminal to reset your local instance password and attempt to login again.

docker exec -ti wandb-local bash
/usr/local/bin/local password <admin_email@domain.com>

@mohammadbakir Thank you for your response! I posted this same issue on the wandb github. Here is the link: [App]: Credentials rejected when signing into localhost:8080 for wandb local · Issue #4080 · wandb/wandb · GitHub. I’ll continue to post on the github as they recommend a similar potential solution.

Hi @aclifton314 , great, thank-you for the update. I will mark this resolved on my end. The steps Frida recommended are exactly what you should do. Cheers!