Triangular Mesh Shows as smooth

I send in one of my projects a mesh and would like to see the triangulated mesh but always see the smooth version.

Is there a setting I could set to see the triangulated version?

Thank you:)

Hi @ilayshvo! Thank you for writing in!

Could you please point me to a workspace where you are experiencing this behavior?

What version of wandb are you using? Are you using any external libraries?

Hey Artsiom,

thank you for the reply.

This is a workspace I work on currently: workspace

I currently use wandb==0.15.0 and I am loading the 3DObject from an OBJ file.

Thank you so much for sending it over!

I see what is happening, although you are expecting your model to be made up off of triangles, the 3d model is completely smooth without texture, Is this the behavior you are seeing as well?


I try would like to see if I get better results before the last best loss and cannot really compare this way…

Unfortunately, there isn’t a way to turn on the triangulation for the mesh. I would love to submit a feature request for you to our engineering team if you are interested though to add this feature to wandb in the future.

That would be great.

Maybe I will get the chance to use it in future projects:)


I have submitted the feature request to our product team. I will follow up with you if we have any questions regarding this topic for you! :slight_smile:

Thank you for your time!