Could not add summary columns for display in Table

Related: Unable to manage columns in project run table - #4 by artsiom

I was unable to make step metric columns visible in the Table view. I tried logging metrics both via run.log and wandb.log, as well as refreshing the page in my browser. When attempting to drag and drop a column name from “Hidden Columns” to “Visible Columns” (see the screenshot), a gap is created, but on mouse release the column name returns to “Hidden Columns”. Clicking on column names to move them to “Visible” does not work either. The logged values appear in the web interface elsewhere. Manipulation with non-metric columns (e.g. config values, name, state etc) worked flawlessly as expected.

The problem remained for a fraction of a minute after I logged a summary metric using wandb.summary[...] = .... In particular, I tried moving all columns by pressing “Show all”, but without any visible result, and I closed the pop-up (on the screenshot). Suddenly, after 10 or so seconds, all columns became visible.

The problem is similar to the one in the linked post. Unlike there, in my case, refreshing the web-page did not seem to help. I’ll take a wild guess and suggest possible reasons for the bug:

  1. Something was going on in your back-end, and I had to wait till all necessary data validation or calculations are completed that would enable adding metric columns. This is unacceptably long time (several minutes), within which I was able to read relevant reference, search issues, and do a couple of empty test runs to see what’s going on.
  2. There is a bug which prevents conversion step metrics to summary metrics unless at least one summary metric is explicitly added via wandb.summary.

I hope you will be able to get to the bottom of it and fix it.

I hope this helps.


Just to clarify. Treat this message as an incomplete bug report. The problem caused me some trouble, but disappeared on its own. Other people experienced the same problem in the past, so it is real.

Hi @avm21 , thank you for writing in with your observations and providing a detailed report. This was a known issue in the past that was addressed by our app team. We will run some tests on our end and flag this for review. I will keep you updated with our findings.

1 Like

Hi @avm21 , I’ve been able to to consistently reproduce this behavior on my end and flagged it as a bug. I will update you on a timeline for a fix once I have additional info. Thanks again for the insight!

1 Like

This actually happened to me when I used the Edge browser, reloading the page or restarting the project did not solve the issue. However, the issue disappeared somehow after reloading the table again after around 30 mins. So maybe it has to do with the browser? I never had this issue while using Chrome/Brave.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.