Cannot login after passing a wrong secret key

After passing a wrong key value and initiating a run like below:

wandb.login(key=<wrong_key> relogin=True)
run = wandb.init(entity=<entity_name>, project=<project_name>)

I can’t use the same kernel session to initialize a new run even passing the right key value. I’ve tried to remove all the wandb related lines of ~/.netrc (as subprocess) and even remove and reinstall wandb in the same kernel.

Has someone faced the same issue and might know how to fix it during without restarting the kernel?

Hi Wilson, thank you for writing in! Have you tried deleting the whole .netrc file completely and using wandb login --relogin? Also, can you tell us more as to why you can’t restart your kernel?

Hi Wilson,

We wanted to follow up with you regarding your support request as we have not heard back from you. Please let us know if we can be of further assistance or if your issue has been resolved.

Hi @wnk, since we haven’t heard back we’ll close this issue for now but feel free to respond here if this is still a problem and we can look into this more.

Thank you,
Nate