Yolov5 creates wandb run with vscode jupyter notebook, but not with same nb in jupyterlab

When I run the same notebook with the same jupyter kernel (custom conda env) in vscode and in jupyterlab, it only creates a wandb run in vscode, but not in jupyterlab.

Output in jupyterlab (no output from wandb):

Training with yolov5: yolov5_model_size: yolov5s batch size: 8 for 180 epochs
train: weights=yolov5s.pt, cfg=, data=dataset/yolov5_config.yml, hyp=yolov5/data/hyps/hyp.scratch-low.yaml, epochs=180, batch_size=8, imgsz=1280, rect=True, resume=False, nosave=False, noval=False, noautoanchor=False, noplots=False, evolve=None, bucket=, cache=None, image_weights=False, device=, multi_scale=False, single_cls=False, optimizer=SGD, sync_bn=False, workers=8, project=yolov5/runs/train, name=exp, exist_ok=False, quad=False, cos_lr=False, label_smoothing=0.0, patience=100, freeze=[0], save_period=-1, seed=0, local_rank=-1, entity=None, upload_dataset=False, bbox_interval=-1, artifact_alias=latest
github: up to date with https://github.com/ultralytics/yolov5 βœ…
YOLOv5 πŸš€ v7.0-71-gc442a2e Python-3.10.9 torch-1.13.1+cu117 CUDA:0 (NVIDIA GeForce GTX 1070 with Max-Q Design, 8120MiB)

hyperparameters: lr0=0.01, lrf=0.01, momentum=0.937, weight_decay=0.0005, warmup_epochs=3.0, warmup_momentum=0.8, warmup_bias_lr=0.1, box=0.05, cls=0.5, cls_pw=1.0, obj=1.0, obj_pw=1.0, iou_t=0.2, anchor_t=4.0, fl_gamma=0.0, hsv_h=0.015, hsv_s=0.7, hsv_v=0.4, degrees=0.0, translate=0.1, scale=0.5, shear=0.0, perspective=0.0, flipud=0.0, fliplr=0.5, mosaic=1.0, mixup=0.0, copy_paste=0.0
ClearML: run 'pip install clearml' to automatically track, visualize and remotely train YOLOv5 πŸš€ in ClearML
Comet: run 'pip install comet_ml' to automatically track and visualize YOLOv5 πŸš€ runs in Comet
TensorBoard: Start with 'tensorboard --logdir yolov5/runs/train', view at http://localhost:6006/
Overriding model.yaml nc=80 with nc=1

                 from  n    params  module                                  arguments

Output in vscode jupyter notebook (shows output from wandb with link to run):

Output exceeds the size limit. Open the full output data in a text editor
Training with yolov5: yolov5_model_size: yolov5s batch size: 8 for 180 epochs
wandb: Currently logged in as: tleyden (eyepi). Use `wandb login --relogin` to force relogin
train: weights=yolov5s.pt, cfg=, data=dataset/yolov5_config.yml, hyp=yolov5/data/hyps/hyp.scratch-low.yaml, epochs=180, batch_size=8, imgsz=1280, rect=True, resume=False, nosave=False, noval=False, noautoanchor=False, noplots=False, evolve=None, bucket=, cache=None, image_weights=False, device=, multi_scale=False, single_cls=False, optimizer=SGD, sync_bn=False, workers=8, project=yolov5/runs/train, name=exp, exist_ok=False, quad=False, cos_lr=False, label_smoothing=0.0, patience=100, freeze=[0], save_period=-1, seed=0, local_rank=-1, entity=None, upload_dataset=False, bbox_interval=-1, artifact_alias=latest
github: up to date with https://github.com/ultralytics/yolov5 βœ…
YOLOv5 πŸš€ v7.0-71-gc442a2e Python-3.10.9 torch-1.13.1+cu117 CUDA:0 (NVIDIA GeForce GTX 1070 with Max-Q Design, 8120MiB)

hyperparameters: lr0=0.01, lrf=0.01, momentum=0.937, weight_decay=0.0005, warmup_epochs=3.0, warmup_momentum=0.8, warmup_bias_lr=0.1, box=0.05, cls=0.5, cls_pw=1.0, obj=1.0, obj_pw=1.0, iou_t=0.2, anchor_t=4.0, fl_gamma=0.0, hsv_h=0.015, hsv_s=0.7, hsv_v=0.4, degrees=0.0, translate=0.1, scale=0.5, shear=0.0, perspective=0.0, flipud=0.0, fliplr=0.5, mosaic=1.0, mixup=0.0, copy_paste=0.0
ClearML: run 'pip install clearml' to automatically track, visualize and remotely train YOLOv5 πŸš€ in ClearML
Comet: run 'pip install comet_ml' to automatically track and visualize YOLOv5 πŸš€ runs in Comet
TensorBoard: Start with 'tensorboard --logdir yolov5/runs/train', view at http://localhost:6006/
wandb: Tracking run with wandb version 0.13.9
wandb: Run data is saved locally in /home/tleyden/Development/seal-face-detection/wandb/run-20230118_182447-02ee6gxj
wandb: Run `wandb offline` to turn off syncing.
wandb: Syncing run kind-meadow-202
wandb: ⭐️ View project at https://wandb.ai/<projectname>/train
wandb: πŸš€ View run at https://wandb.ai/<projectname>/train/runs/02ee6gxj
Overriding model.yaml nc=80 with nc=1

                 from  n    params  module                                  arguments         

Is there anything I can try in jupyterlab to get it to work? If needed, I don’t mind running it only in jupyterlab if it’s not possible to switch back and forth between the two editing environments.

Hi @tleyden ! I can help look into this for you. Could you share what version of W&B you are currently using and the debug.log and debug-internal.log files associated with the runs you have linked here? They should be present in a folder called wandb in your working directory.

Hi @tleyen,

We wanted to follow up with you regarding your support request as we have not heard back from you. Please let us know if we can be of further assistance or if your issue has been resolved.