The setting of environment variables

The first time I used wandb login from the command line, I encountered the error PermissionError: [Errno 13] Permission denied: ‘/tmp/.config/wandb/’.
However, I have checked that the permissions on the /tmp folder are: “rwxrwxrwt”, and I can also create new files in /tmp. I hope i can get the answer about the permission of the tmp file.

Later, using the developer guide, I temporarily solved this problem by using os.environ[“WANDB_CONFIG_DIR”] = op.join (OS.getcwd (),“tmp”)
in my py file.

However, I didn’t want to add such a paragraph to my script every time, so I tried adding environment variables to the.bashrc file. However, when I source.bashrc, “WANDB_DIR: command not found” is displayed. I am also looking forward to your answer on how to correctly set environment variables

Hi @matrixmax, is tmp/ the root directory on this machine? That config file should normally end up in ~/.config/wandb/settings unless this path is unwritable. It may be worth figuring out why wandb doesn’t have access to write to ~/

Also, could you let me know how you were attempting to set this in your bashrc?

Thank you very much for your reply, the “tmp” directory I mentioned is the root directory of the system, namely: the “/tmp” folder.
Do you mean that I should check the permissions for the “~/.config/” folder? Okay, I’ll go back and try
The Settings in.bashrc are shown in the following figure. The directory used was the tmp folder I created in my own home directory.

Hello! It looks like Python doesn’t have permissions to write to the .config/wandb file and you probably need to use chmod to update the permissions. Have you checked the permissions for the “~/.config/” folder and were you able to fix this issue after changing the permissions?

Thank you very much for your reply! I have checked that the permissions for the “~/.config/” directory are:

drwxrwxr-x 10 wxl wxl 10 Sep 19 10:03 .config/

, and the permissions of the “/tmp” directory are:

drwxrwxrwt 3970 root root 159744 Sep 27 11:06 tmp/

But that still doesn’t solve the problem

Could you try to make a new environment or try a separate environment to try this in? We do not have any known permissions issues on our end and all the signs seem to point to this being an environment-based permission issue. Hopefully this can be solved with a different environment since it purely looks like your current environment is having issues.

Hi xingliang, since we have not heard back from you we are going to close this request. If you would like to re-open the conversation, please let us know!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.