Run initialization has timed out

I tried to run the sample code on the official website(my-awesome-project) but got this error, can anybody help me?

Since I’m a new user, I can’t paste debug-internal.log here. If possible, please leave your email address so that I can send my debug-internal.log and debug.log.

Hi @castti Good day and thank you for reaching out to us. Happy to help you on this!

Can you try to relogin again using wandb login --relogin to force relogin and see if this now allows you to run your code?

You can upload the logs here -


Thank you for your willingness to help me!

I’ve tried to login again using “wandb login --relogin”, but it doesn’t work. And here are my logs.


Hi @castti We normally see connection issues when it comes to machines behind VPNs, Proxies, or Load Balancers. Are you using one of these on your current instance/environment where you are running your script?

Hey @paulo-sabile, thanks for the reply.
My server does not have VPNs or Proxies enabled. I think the connection issues may be caused by my being in China. So I started the offline training on the server, and tried to upload the logs from my pc to the web. But there are still problems, as shown in the pictures below.
I also tried using a VPN and got an error: wandb: Network error (ProxyError), entering retry loop. (Due to the limitations of new users, I only embedeed one image)

Hi @castti Thank you for sharing that error message. That error indicates that it could be due to a network connection. This usually occurs when your computer loses access to the internet. Just to rule out this assumption, will it be okay for your to perform diagnostics with your internet connection?

Hi @paulo-sabile I think there is something wrong with my internet connection.
I can ping from the pycharm’s terminal, but fail to ping What should I do in this situation?

Hi @castti I am not sure if that is something that needs to be dealt with by your internet provider. Or if you are using a company machine, you can check with your local IT for this. However, do you have a different machine where you can run a test ping to

Hi @paulo-sabile All my devices failed to ping
I found that whether I could ping had nothing to do with whether I could connect to wandb’s site. Because I successfully uploaded the offline log using the laptop connected to the mobile hotspot, but the upload failed when the laptop was connected to the school network. I think the school network has a restriction on wandb’s site.
I have now found a way to upload the logs to the network: start the offline training on the server, upload the logs to my laptop, connect to the phone hotspot, and then upload to the network. Thank you so much for your help!
I also found that my pc can ping successfully, but failed to uploading offline logs. Do you have any ideas about that? (My pc has no wifi module, so it can only connect to the school network.)

I’m also getting a run initialization has timed out error across multiple servers in the last few hours.
It’s worth noting that this error doesn’t happen all the time. I tried re-running a few times and after a few tries the error didn’t appear once then it appeared at the next try.

Hey @edwin_ed520 There was an outage during the weekend but this should be resolved now.

Hi @castti Unfortunately if is being blocked so I would suggest to check what restrictions they have in your school network. If you can reach out to anyone that manages their network, might help identify what is blocking our site. I hope this helps! Thank you