404 response executing GraphQL

When I execute wandb.login() in pycharm or jupyter notebook, I got the error below:
404 response executing GraphQL
404 page not found

and then True is printed. However, when I run wandb.restored(…), I get the error below:
CommError: Permission denied, ask the project owner to grant you access

It works well in colab. What is the issue?
I am using Win11 with the latest version of wandb

I should add that I could log in to my wandb account without issue, but recently I get the errors mentioned.

Hi @sajmahmo,

At a first glance, looks like the API key you have entered on your windows 11 machine might be wrong. Could you call wandb.login(relogin=True) and re enter your key from Weights & Biases in order to check if this could be the case?


Thanks for the response.
It has been already solved. I don’t know why it happened. Maybe because I remotely logged in to my account from another IP in US while I regularly connect from my local machine in Belgium .

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.