Cannot connect to Amazon S3 from self hosted wandb

I’m trying to setup a self hosted wandb on k8s using helm charts. Unfortunately, I am not able to connect to my Amazon S3.

I tried two ways:

  1. Based on the example here On Prem / Baremetal - Documentation, I used the format:
    s3://myaccess:myseceret@s3.amazonaws.com/ofer-bucket-1
    However when the wandb pod starts, it says that the URL is not valid, as “:mysecret” is not a valid port.
    For some reason it considers the secret to indicate URL port and not secret

  2. I also tried changing my bucket to public, but wandb pod failed to initialize again, this time with error 403 access denied.

Anyone has an example for the correct format of the BUCKET value or can explain how it should be structured? I prefer to have it with access/secret key. But I’m ok with public as well.

Hi @oferla , happy to help you resolved this issue. We received your request to our support email and I followed up with request for additional information. I will continue our conversation but keep this discourse thread open for community members to contribute any additional feedback. Cheers!

I’ll post the reply of Chris Van Pelt from WandB support, to assist anyone who encounters this:
The correct format is indeed s3://access:secret@host/bucket
However, each component (access, secret, etc) needs to be url encoded as special characters within them can interfere with the parsing.

@oferla thank you for updating the community with CVPs fix. Happy to hear you were able to successfully setup your instance.