Define_metric parameter 'hidden' not working?


I’m new to W&B and was setting up my metrics like this:

# define x-axes
wandb.define_metric("batch#", hidden=True)   # "hidden" not working
wandb.define_metric("epoch#", hidden=True)
# define metrics and match to x-axis
wandb.define_metric("loss", step_metric="#batch#")
wandb.define_metric("f1", step_metric="epoch#")

I want graphs of loss/batch# and f1/epoch# on my dashboard, but not graphs of batch#/step or epoch#/step. Therefore, I set the function parameter ‘hidden’ to True for these. It does not work, I still get automatically generated panels of them. Any advice?

Hi @tim123 thanks so much for spotting and reporting this issue. We were able to reproduce it on our end, and I have reported it to our engineering team. I also linked this discussion with the internal ticket, so that we can reach out to you here if there are any further updates. In the meantime, these plots can be only manually deleted from the UI.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.