Chrome Inline JavaScript Issue when Rendering Molecules

Hello, everyone.
I recently have been trying to log wandb.Molecule objects via PyTorch Lightning. However, when I view the logged Molecules in my web browser (Google Chrome, Version 95.0.4638.69, 64-Bit), I see the following error, preventing my Molecules from being rendered.

[Report Only] Refused to apply inline style because it violates the following Content Security Policy directive: “default-src ‘none’”. Either the ‘unsafe-inline’ keyword, a hash (‘sha256-NFPvvJTeausaOnuU9syzBhm5OjQ9MGcbA9SexsBrsF4=’), or a nonce (‘nonce-…’) is required to enable inline execution. Note also that ‘style-src’ was not explicitly set, so ‘default-src’ is used as a fallback.

It looks to me like Chrome is preventing WandB’s web site from rendering inline JavaScript. For reference, I have disabled any browser extension that may be affecting this, and that didn’t seem to help.
Any ideas as to how to get around this issue? Without of course using a new browser :wink:

Hi @amorehead!

Thank you for your question! This seems to be an issue on our end. I have notified the engineers of this issue and we will have it resolved ASAP.

Thank you,
Ramit
Weights & Biases Support

Hi @amorehead! This problem has been fixed, you should be able to render molecules in your workspace now.

Ramit,

Thank you very much for letting me know, and please thank the team on my behalf for their very quick response!

Best,
Alex