About Network error (TransientError)

I get below error message when starting a new run:

wandb: Network error (TransientError), entering retry loop.

Some metrics can be uploaded successfully, but some metrics are not (cannot be found in the UI).

I have determined that it is an internet connection problem because this problem is solved when I change WIFI connection from A to B.

I would like to know if there is any way to guide the network operator to fix the network A. Is ping command can help (should try to decrease the packet loss)?

PING www.wandb.ai (151.101.1.195): 56 data bytes
64 bytes from 151.101.1.195: icmp_seq=0 ttl=42 time=258.594 ms
64 bytes from 151.101.1.195: icmp_seq=1 ttl=42 time=188.247 ms
64 bytes from 151.101.1.195: icmp_seq=2 ttl=42 time=186.654 ms
64 bytes from 151.101.1.195: icmp_seq=3 ttl=42 time=189.388 ms
64 bytes from 151.101.1.195: icmp_seq=4 ttl=42 time=228.432 ms
64 bytes from 151.101.1.195: icmp_seq=5 ttl=42 time=280.176 ms
64 bytes from 151.101.1.195: icmp_seq=6 ttl=42 time=324.054 ms
64 bytes from 151.101.1.195: icmp_seq=7 ttl=42 time=215.211 ms
64 bytes from 151.101.1.195: icmp_seq=8 ttl=42 time=224.348 ms
Request timeout for icmp_seq 9
64 bytes from 151.101.1.195: icmp_seq=10 ttl=42 time=311.803 ms
64 bytes from 151.101.1.195: icmp_seq=11 ttl=42 time=187.057 ms
64 bytes from 151.101.1.195: icmp_seq=12 ttl=42 time=189.397 ms
64 bytes from 151.101.1.195: icmp_seq=13 ttl=42 time=196.487 ms
64 bytes from 151.101.1.195: icmp_seq=14 ttl=42 time=195.504 ms
64 bytes from 151.101.1.195: icmp_seq=15 ttl=42 time=194.557 ms
64 bytes from 151.101.1.195: icmp_seq=16 ttl=42 time=189.196 ms
64 bytes from 151.101.1.195: icmp_seq=17 ttl=42 time=185.882 ms
^C
--- www.wandb.ai ping statistics ---
19 packets transmitted, 17 packets received, 10.5% packet loss

Hi Yao, is there a reason why you can’t use network B to run your models? Trying to reduce the packet loss is always a great idea

Thank you for the reply! I suppose many Chinese users have encountered this network error because of using the network provided by the same Network Operator (NO). Switching to another Network Operator is not very easy for everyone. I want to report this issue to the NO but I don’t know how to describe it. Does there exist the testing address can be used for fixing this issue?